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Notice

The information in this document is subject to change without prior notice in order to improve 
reliability, design, or function and does not represent a commitment on the part of this company.

In no event will we be liable for direct, indirect, special, incidental, or consequential damages 
arising out of the use or the inability to use the product or documentation, even if advised of the 
possibility of such damages.

Copyright © 1997 – 2024 SoftLab-NSK LLC
All Rights Reserved.

No part of this reference manual may be reproduced or transmitted in any form or by any means 
without the prior written permission of this company.

Throughout this manual, we make reference to product names that are trademarks of other 
companies. We are using these names for identification purposes only, with no intention of 
infringement of the trademarks.

FCC Information

FCC ID:	

This equipment has been tested and found to comply with the limits for a Class B digital device, 
pursuant to Part 15 of the FCC Rules.  These limits are designed to provide reasonable protection 
against harmful interference in a residential installation.  This equipment generates uses and can 
radiate radio frequency energy and, if not installed and used in accordance with the instructions, 
may cause harmful interference to radio communications.  However, there is no guarantee that 
interference will not occur in a particular installation.  If this equipment does cause harmful 
interference to radio or television reception, which can be determined by turning the equipment 
off and on, the user is encouraged to try to correct the interference by one or more of the following 
measures:

Reorient or relocate the receiving antenna.
Increase the separation between the equipment and receiver.
Connect the equipment into an outlet on a circuit different from that to which the receiver is 
connected.
Consult the dealer or an experienced radio/TV technician for help.

Shielded cables and I/O cards must be used for this equipment to comply with the relevant FCC 
regulations. Changes or modifications not expressly approved in writing by SoftLab-NSK Ltd. may 
void the user’s authority to operate this equipment.

Limited Warranty

Our company warrants this product against defects in materials and workmanship for a period of 
one year from the date of purchase.  During the warranty period, products determined by us to be 
defective in form or function will be repaired or replaced at our option, at no charge.  This warranty 
does not apply if the product has been damaged by accident, abuse, misuse, or as a result of service 
or modification other than by us.

This warranty is in lieu of any other warranty expressed or implied.  In no event shall we be held 
liable for incidental or consequential damages, such as lost revenue or lost business opportunities 
arising from the purchase of this product.
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Introduction

Forward Sports Titles is a software and hardware complex for 
graphic design of live broadcasts of sports competitions.
 

The Forward Sports Titles system includes the FDExt board 
(SD/HD/3G-SDI) and software. The system allows you to 
overlay graphics on passthrough video on the server or output 
a signal in Fill+Key mode to overlay graphics using an external 
mixer. 

Graphics meets the requirements of sport leagues (KHL, FIBA, 
etc.). Personal design can be also used.

Each type of sport has its own version of the system that meets 
the requirements of corresponding league in terms of content 
and scope of information, rules of competitions, design of 
graphics, etc.

The system operates in a real-time mode. The following 
functions are available:

1.	 Control over output of graphics on air:
●● output of static information:

●● information about championship: title, league 
logotype, coach full name; name of stadium;

●● information about teams: title, logotype, full name 
of coach;

●● information about players: number, full name, 
photo, statistics, etc.;

●● output of dynamic information about course of 
game: score, play time, period number, goals, bullits, 
removals, etc.;

●● preview of graphics before output on air;
●● 2 modes of graphics stop – usual mode (with 
animation) and emergent mode.

2.	 Completion of database tables with information about game:
●● interaction with websites of sport leagues (for 
example, KHL) for completing teams database;
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●● input of information about game and teams from 
prepared CSV files;

●● input of information manually.
3.	 Input of information about course of game in a real-time 

mode:
●● integration with game board (game controller) in 
a real-time mode –  automatical output of dynamic 
information about game;

●● input of dynamic information about game by sports 
graphics operator manually;

●● configuration of start/stop of play time timer by 
external GPI event. Information in graphics is 
updated if some data is modified in it. 
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General Information

General Description of System

1. Installation
The Forward Sport Titles software set is delivered to customer 
as a «turnkey» video server equipped and configured for a 
specific sport and stadium (championship). 

2. Software Set and Purpose of Programs
The Forward Sport Titles software set includes the following 
components:

1.	 SLSportDataBaseService – a server that ensures work with 
database.

2.	 SLSportTeamsEditor – an editor of database (work with 
static information – text, photo). 

3.	 SLIceHockeyReferee / SLBasketballFIBAReferee 
/ SLFootballReferee / SLHandballReferee / 
SLVolleyballReferee (depending on sport) – programs 
for integration with a game board or for input dynamic 
information manually (play time, goals, removals, bullits). 
Hereinafter referred to as SL***Referee.

4.	 SLSportTitler is a program designed to control a display of 
sports graphics.
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3. Scheme of Work
The Forward Sport Titles system has 3 work places:

●● work place for editor: editing database with text and 
graphic information;

●● work place for referee: input of information about 
game;

●● work place for sport graphic operator (CG assistant): 
display of titles.

1.	 Сomplete database in the SLSportTeamsEditor editor (1) at 
stage of preparation for streaming. Database (*.TitleDB file) is 
used for storing information about players, referees, teams, 
etc. Data can be input automatically or captured from KHL 
website and other leagues or extracted from prepared CSV 
files or entered by editor manually. Images can be stored in 
database besides text information, for example, photos of 
players. 

2.	 Set of graphic files with graphic design is created in the 
Microsoft Expression Blend program (2) in advance. 
As a rule experts of the SoftLab-NSK company are 
responsible for development and support of graphics up to 
date. Design is created for specific games season of a specific 
sport meeting all requirements of corresponding league 
(association, championship, etc.). 
User creates project in the SLSportTitler program:  
*.SLSportTitleCfg (3) where he specifies all paths to design and 
database configuration files.

1

2

4

5

3
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3.	 The SL***Referee plugins (4) (for each type of sport its 
own: SLIceHockeyReferee / SLBasketballFIBAReferee 
/ SLFootballReferee / SLHandballReferee / 
SLVolleyballReferee) are program modules used to input 
information about course of game to system in a real-time 
mode. The modules ensure integration with game board 
(game controller) on stadium or input of dynamic information 
manually (play time, number of period, goals, removals, 
bullits).
Description and parameters of game (quantity of periods 
and their duration, maximal quantity of removals, fouls, 
timeouts) are specified in advance in xml file of game 
description. For example, the IceHockey.xml file is file for 
hockey. Path to file is specified in a command string of  
the SLIceHockeyReferee.exe program.

4.	 Control over input of graphics on screen is executed in the 
SLSportTitler main program window (5).  
File of the *.SLSportTitleCfg project has a set of buttons 
used for display of specific graphics with information from 
database and from program for input of dynamic data about 
game. 

5.	 Sources of data for output sports graphics:
●● database prepared in advance for a specific 
championship and specific game;

●● information from game board.
6.	 There are 3 shortcuts on a desktop for each sport:

●● SLSportTeamsEditor is database of game with 
corresponding configuration files,

●● SLIceHockeyReferee / SLBasketballReferee / SLFootballRef-
eree / SLHandballReferee / SLVolleyballReferee contains 
description of periods for specified sport,

●● SLSportTitler is used to control output of graphics for 
specified sport. 
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Work Order With Forward Sport Titles Software

1. Completion of Database in SLSportTeamsEditor
The major part of information is stored in database. 
Completion and editing of database are executed in the 
SLSportTeamsEditor in advance before game streaming.

1.1. Modes of Work With Database
There are 2 modes of database completion:

●● manual – information about teams and players is 
taken from *.csv configuration files and is entered to 
tables of the SLSportTeamsEditor program:

●● Game;
●● Translations;
●● Information about the first/second teams;
●● Players of the first/second teams.

●● automatical – information is taken from websites of 
sport leagues (KHL, etc.) by clicking KHL in menu of 
the Information about the first/second teams tables. For 
a correct work of the KHL button configure login and 
password to get an access to KHL website. 

1.2. Database Structure
Tree with folders on disk is the following: there is a general 
folder with name of future game or championship (for example, 
KHL-2019) that includes the following subfolders:

●● Base (1) subfolder with all files of game database and 
information about players:

●● Colors;
●● Flags;
●● Logo;
●● Photo;
●● PhotoCOACHES;
●● PhotoPLAYERS;
●● Weather;

●● CSV (2) subfolder with configuration files with data 
tables:

●● Game Event.csv;
●● GameInfo.csv;
●● TranslateEng.csv;
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●● TranslateRus.csv;
●● TeamInfo.csv;
●● TeamPlayers.csv;

●● Design (3) subfolder with set of fonts Font and 
subfolders with files of graphics:

●● Coach;
●● CountDown;
●● DownScore;
●● Font;
●● GeoTitle;
●● Player;
●● Referees;
●● RefereesNoPhoto;
●● Sostav;
●● Starting;
●● TotalScore;
●● UpScore.

Root of the general folder with title of game must store *.SL-
SportTitlerCfg project files (4) and *.TitleBD file of game (5) and 
teams database.

88 	Important: File with database (*.TitleDB) and file with project (*.SLSport-
TitleCfg) must be stored in one folder for a correct work with 
images. 

1.3. Launch of SLSportTeamsEditor
There is one current database for a concrete game and sport in 
the system. If sport is changed then user must change current 
database. 

For this create new database in a corresponding folder or open 
earlier created database and save it obligatory (select File > Save 
or File > Save As Menu commands). Only after saving database 
user can launch SL***Referee or SLSportTitler.exe programs. 

1

3
4

5

2
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At further opening of current database it is not obligatory to 
save it. It is enough to open database and close the program. 

88 	
Important: If there is the Font subfolder in the Design folder with design 

then user must install all fonts from this folder on PC in 
advance.

File for program execution is:  
~\ForwardT Software\Plugins\SLSportTitler\bin\DBEditorSLSBInfo.exe, 
where ~ is a full path to folder with software. Use the Start Menu 
command to launch the program: ForwardT Software > SL Sport 
Teams Editor or shortcut located on a desktop. 

„„ 	 Tip: Specify a unique string in shortcut configuration window, for 
example, title of sport in order for program to remember path 
to the last project. It simplifies operating if user works with 
one system for different sports. Each sport has its own path to 
project.

The main SLSportTeamsEditor program window with empty 
tables at the first program launch appears:
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1.4. SLSportTimesEditor Main Program Window
At restart of the program database of the previous game 
appears. 
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1.5. CSV Configuration Files
The SLSportTeamsEditor program deals with *.csv 
configuration files where columns of different tables are 
described:

●● GAME – contains fields that are independent 
from player or team. It stores information about 
championship, stadium, season, outside temperature, 
league logotype, etc. Configuration file is GameInfo.csv;

●● TRANSLATIONS – contains fields with all text captions 
presented in different designs that are invariable 
depending on player, team or stadium. Captions in 
graphics must be translated into Russian or English. 

Main program window. Control elements: 
1 – main menu; 2 – buttons used for a quick activation of database commands; 3 – table with general 
information about game; 4 – table with translation of text captions that are invariable depending on 
team or stadium; 5 – table with information about team 1; 6 – table with information about team 2; 
7 – table with information about players of team 1; 8 – table with information about players of team 
2; 9 – button used to load information about teams from database of KHL website; 10 – button used 
to clear information in table; 11 – import of information from *.csv configuration file; 12 – export of 
information to *.csv configuration file; 13 – add new player to team; 14 – delete selected player from 
team; 15 – indicator of work with FIBA statistics; 16 – change language of program interface.
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All the captions are stored in the CSV subfolder. Text 
in Russian is specified in TranslateRus.csv file, text in 
English is specified in TranslateEng.csv file. Table is 
updated from corresponding file automatically if the 
program is restarted or if user changes language;

●● Information about team 1 – contains information about 
team 1 (on the left): title, logotype, referee full name, 
etc. Configuration file is TeamInfo.csv;

●● Information about team 2 – contains information about 
team 2 (on the right). Configuration file is 
TeamInfo.csv;

●● Players of team 1 – contains information about players 
from team 1: number, name and surname, photo, 
weight, height, etc. Configuration file is  
TeamPlayers.csv;

●● Players of team 2 – contains information about team 2. 
Configuration file is TeamPlayers.csv.

88 	Important: We recommend making all captions in capital letters.

1.6. Editing Data in Database

Click  in SLSportTeamsEditor tables or use the Edit > Import 
from CSV command of the main program menu to work with 

*.csv configuration files. Click  or use the Edit > Export to CSV 
command of the main program menu to save data after editing.

Data in tables can be edited in program window by double-
clicking table cell. Text data is edited by integrated text editor 
in table cell (1). 

Click corresponding cell (2) to replace image. Standard 
dialog window for selecting file appears. Relative path to file 
is registered after cell selecting. Path is specified relatively 
current file of database. So, right after creation of new database 
user must save it to disk and only then edit data from database.

1

2

3
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Table with information about players has the  and  

buttons (3). The  button is used to create new string in 

table. The  button is used to delete string from table. 
The first «#» column sets order by which players in the 
SLSportTitler program are loaded.

88 	
Important: 

User must click the  button each time after editing data to 
save it to database (File > Save menu). User must click any other 
cell of table after editing text data for integrated editor to enter 
edited data to database cell. 

1.7. Loading Data From KHL Database

The  button in Information about the first/second team tables 
is used to import statistics for selected team. Complete the 
following for this:

1.	 Configure access to server with KHL statistics. Execute the 
Edit > Settings command of the main window. The Settings 
window (1) appears.

1

2

2.	 Specify login and password in the User and Password  
fields (2) to get access to website with statistics http://stat2tv.
khl.ru (user gets data at KHL individually). It is enough to 
specify the settings once. 

3.	 Click the  button in the Information about team 1 table (3). 
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3

4.	 The Import from KHL Database command (4) in window 
appears. Select language for display of database information 
from (5) drop-down list. Then select command to load 
statistics (6). Click Import (7).

5.	 Complete the following after importing:
1. Select logotype of team from the Base\Logo folder (1).
2. Select colours for teams (colour background for logotype) 
from the Base\Colors folder (2).

of
1 2

3. Specify name and surname of team coach (in capital 
letters) (3).

3

4. Delete «unregistered» players from list (players that do 
not participate game).

4

5

6

7
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5. Specify starting five in the Pos5 column (4). Left forward 
is specified under 1, center forward is specified under 2, 
right forward is specified under 3, left back is specified 
under 4, right back is specified under 5, goal-keeper is 
specified under 6.

4

6. Save database by clicking  or via the File > Save menu 
command.
7. It is necessary to complete information about teams 
statistics (5) during game in First team info and Second team 
info tables in Shots, Faceoffs, Penalty, Powerplay and Shorthand-
ed columns (this information is displayed in the «StatGame» 
graphics) or do not display the «StatGame» graphics at all.

5

6.	 KHL design suppose use of photos of players and coach. 
The program loads photos of players to the Base\PhotoPLAY-
ERS folder from KHL website at when information about 
team is added. Images of players are stored in JPG format 
(without transparency) on website. That’s why display of 
such photos in graphics is not likely. So, we recommend 
converting all photos to PNG format with transparency 
(with cut background behind player) and replacing JPG 
photos in the same folder. All photos must be 400 pixels high 
and not more than 400 pixels wide (for example, 320х400). 
User loads photos of players on http://stat2tv.khl.ru site strictly. 
Photo of coach is loaded automatically. It must be loaded 
separately. CSV file with title of team is generated together 
with completing database with photos.
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2. Design and Animation of Graphics
Design of graphics is created in the Microsoft Expression Blend 
program (1) in advance (by designer of SoftLab-NSK as a rule).

3. Description of Game in XML File
Description of periods (quantity of periods and their duration) 
is specified in XML file similar to file with description of game 
specified in command string. File and the SL***Referee.exe 
application must be stored in the same folder. For example, 
IceHockey.xml is a file for hockey that is stored with SLIceHockey-
Referee.exe module. When SLIceHockeyReferee.exe file is loaded 
a notification with information that description file is found 
appears:

Format of file with description of game (IceHockey.xml, for 
example) has the following format:
<GameDesc PeriodsCount="7" ReverseTime="true" MaxPenaltyCnt="2">

<Period Duration="20"/>

<Period Duration="20"/>

 
1
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<Period Duration="20"/>

<Period Duration="5"/>

<Period Duration="1"/>

</GameDesc>

where: 
●● GameDesc are game parameters: 

●● PeriodsCount is parameter that displays quantity of 
periods in game;

●● Reverse Time is parameter that displays time 
(in minutes): "true" denotes that time is counted 
downwards (from 20:00 up to 00:00);

●● MaxPenaltyCnt is parameter that displays maximal 
quantity of simultaneous removals during game;

●● Period Duration is parameter that displays duration of 
periods in minutes. There are 7 periods in game in 
the given example. The first 3 periods last 20 minutes 
each, the fourth period is 5 minutes, the fifth and the 
sixth periods are 1 minute each. The last, the seventh 
period is needed to display captions at the end of the 
game only.

Files with description of games in other sports differ by 
parameters (another quantity of periods and their duration, 
direct counting or downwards, quantity of timeouts, etc.).
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4. Work in the SL***Referee Program 
All programs for input of referee information are – 
SLIceHockeyReferee, SLFootballReferee, SLBasketballReferee, 
SLVolleyballReferee, SLHandballReferee. The programs have 
the following functional set:

●● input of dynamic information – play time, number of 
period, score, foul shots, removals, etc.;

●● interaction with game board (game controller) in a 
real-time mode;

●● automatical start/stop of play time by external GPI 
event.

Interface of SL***Referee programs for different sports is 
different. 

Let us consider order of work on example of the 
SLIceHockeyReferee program. 

Note: The SLIceHockeyReferee program is used for input of referee 
information for hockey and handball sports.

4.1. Program Launch
File for program execution is: ~\ForwardT Software\Plugins\ 
SLSportTitler\bin\IceHockeyReferee\SLIceHockeyReferee.exe,  
where ~ is a full path to folder where software is installed. 

Use the Start Menu command to launch the program: ForwardT 
Software > SLIceHockey Referee:

At program start titles of teams are imported from current 
database last time saved by SLSportTeamsEditor.

4.2. Main Program Window
The SLIceHockeyReferee main program window has blocks of 
elements for control dynamic information:

●● Time&Score info block (2) is used to control input of data 
about time and score (total and by periods);

●● Penalty info block (16) is used to control penalties.
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Main program window. Control elements: 
1 – main menu; 2 – Time&score info area displays information about time and score; 3 – fields with 
titles of teams Team1 and Team2; 4 – area with game score Score (total and period), Total drop-
down lists: display distribution of goals by periods and total score for each team; 5 – correct score in 
finished periods; 6 – area with score in current period; 7 – two buttons + left and right – increase score 
(for both teams); 8 – number of current period; 9 – countdown of period time (timing can be direct in 
some sport); 10 – increase/decrease play time in 1 sec.; 11 – start/stop period timing; 12 – correct period 
time (available only when game is stopped); 13 – open the Shootouts window (window for input of 
shootouts); 14 – put the Empty Net mark –  to replace goalkeeper by field player; 15 – put the Delayed 
Penalty – to delay time of penalty; 16 – area with information about penalties; 17 – two buttons Add 
Penalty – add another penalty for corresponding team; 18 – time of penalty in minutes; 19 – table 
with list of removed players (Team and Time – rest penalty time); 20 – buttons used to correct time of 
penalty selected in table; 21 –  delete selected penalty.
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4.3. Settings
1.	 The File > Config menu command (1) is used to open the Set-

tings window (2) to configure automatic control over time and 
other parameters.

1

Location of database and time server are specified in the 
Database (3) and Time server fields (4). It is not recommended 
to change them.

  
     

2

3

4
5

6
7

8

2.	 User can put checkboxes if the system is configured to 
connect to game board:

●● Use score-board‘s time info (5) – use information about 
time from game board;

●● Use score-board’s score info (6) – use information about 
score from game board;

●● Use score-board’s penalties info (7) – use information 
about penalty time from game board. 

Putting these checkboxes denote enabling automatic import 
of information from game board. It simplifies interface of the 
main program window:
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„„ 	 Tip: Appeal to SoftLab-NSK technical support to connect to game 
board.

3.	 User can configure start/stop of play time timer by GPI 
events via the Config GPI button (8) in the Settings window.

4.4. Work in Program
1.	 Complete the File > Restart command (1) to restart game.

1
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Work of operator who inputs information manually is described 
below. 

2.	 At program start titles of teams are imported from current 
database last time saved by SLSportTeamsEditor. 
Team1 and Team2 teams titles (2) appear in the main 
program window automatically. 

3.	 Click Start (3) to start play time – the button is displayed as 
Stop during timing. Downwards timing of current period in 
the Time field starts (4).

    

   

4 8 3

2

57

Click Correct time (5) to correct play time. The Correct time 
window (6) appears:

In this window user can change time only when game is 
stopped. The buttons (7) and + (8) to the left and to the right 
of the current time allow user decreasing/increasing current 
time by one second right during the game. 

6
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4.	 The Score (total and periods) area (1) has Total (2) and P1, 
P2, P3 (3) drop-down lists used to display total score and 
distribution of goals by periods in each team.

  

   

4

3
2

1

Click Correct (4) to correct score. The Correct score window 
appears (5):

5

Correct current score in Team1 and Team2 fields in current 
period. Then click ОK.
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5.	 Specify score in current period via check-boxes (3) or buttons  
(4) or + (5) in Score in period area (1) in fields (2).

88 	Important: Note that this score is a score of current period only, not a total 
score.

6.	 Specify number of current period via buttons (8) or + (9) in 
Period area (6) in field (7).

   

   
     

2

37
54

1

6
8 9



26

7.	 Click the Shootouts button (1) to enable dialog of control 
shootouts.

 

1

The Shootouts window (2) appears.

Specify results in each shootout at completion of tables for 
each team in Shootout 1***5 fields:

●● Init (3) – shootout is not executed yet;
●● Hit (4) – shootout is hit;
●● Miss (5) – shootout is missed.

2

3 4 5
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The Init –  marks (3) are output in graphics before 
making shootouts. 

The Hit –  mark (4) is displayed if shootout is hit, the 
 mark (5) is displayed if shootout is missed.

45

3
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8.	 Specify penalty period (2, 4 or 10 minutes) in the drop-down 
list of the Penalty info block with elements (1) for control 
penalties. Then click Add penalty (3) for corresponding team. 
String with title of team and penalty time (4) in table below 
appears. Downwards timing starts.

   

   
     

5

32
1

4

Select string in table (4) to correct penalty time. The Correct 
time button (5) and corresponding – (6) and + buttons (7) on 
the left and on the right become enabled:

   

   
     

85

76

4

Correct time of player removal via the (6) or + buttons (7).
Select necessary time and click Remove penalty (8) to delete 
string with penalty time in table.

In hockey the UpScore and Bullits graphics update data in 
current image automatically if play time, number of period, 
quantity of goals, removals, penalties or bullits (shootouts) 
are modified. Remaining graphics do not update image if 
corresponding data in SLIceHockeyReferee is modified. So, 
to display updated data user must remove graphics from 
streaming and restream it with updated data again.
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5. Work in the SLSportTitler Program

5.1. General Informaiton About Program
Control of graphics display is executed in the SLSportTitler 
program. To streram game the *.SLSportTitleCfg project with all 
described above settings is saved:

●● in database (SLSportTeamsEditor);
●● in the SL***Referee program designed for input of 
dynamic information (time, score, goals, penalties, 
etc.);

●● paths to folders with graphics design are specified. 
Interface of program allows user displaying prepared screen 
field (graphics) by one button or double clicking. Project with a 
specified set of buttons and design is prepared for each sport. 
For example, for hockey:

1

Each button displays a specific graphics (one screen form) where 
necessary strings are completed by current data imported from 
database or by information extracted from program for input of 
dynamic information. The button can be in one of the followig 
states:

●● Grey – graphics is off (1);
●● Red – graphics is prepared for putput (2) and is 
displayed in preview window (3);
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3

2

●● Green – graphics is ready for streaming or has already 
streamed (4).
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4

5

6

8 7

Usual state of button is grey. At first click it becomes red and 
displays graphics in preview window. When animation is 
finished the button usually becomes green in preview window. 
It denotes that graphics is ready to be streamed and user can 
click the Take button (5) to broadcast graphics on air. User 
can output graphics on air automatically without preview via 
some buttons, for example, the UpScore button (6) (displays 
upper score in hockey). Graphics disappears when user clicks 
the button again (or by the Stop all command (7)). By the Abort 
all command (8) graphics is aborted (FadeOut without final 
animation).

5.2. Program Launch 
File for program execution is:  
~\ForwardT Software\Plugins\SLSportTitler\bin\Titler\SLSportTitler.exe 
where ~ is a full path to folder with software. User must specify 
path to *.SLSportTitleCfg title project in command string. Use the 
Start Menu command to launch the program: ForwardT Software > 
SL Sport Teams Editor or shortcut located on a desktop:

At program start titles of teams are imported from current 
database last time saved by SLSportTeamsEditor. 
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5.3. Main Program Window
Interface of the main program window has a set of graphics 
buttons generated depending database with information about 
game, players and settings completed in the SL***Referee 
program in advance. 

Example of the SLSportTitler main program window for 
broadcasting KHL hockey is given below.
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19

Main program window. Control elements:  
1 – main menu; 2 – the Main tab with buttons to control graphics for each team; 3 – display the 
Sostav graphics – list of players of one of the teams; 4 – display the Starting graphics – starting five of 
one one of the teams; 5 – dislpay the Coach graphics – head coach of one one of the teams; 6 –  display 
the Dressing room graphics – dressing room of one one of the teams; 7 – display the TimeOut graphics 
– game timeout; 8 – display the UpScore graphics – score in current period; 9 – display the Player 
graphics – photo and name of player; 10 – display the PlayerPenalty graphics – photo and name of 
player who makes penalty; 11 – display the PlayerNoPhoto graphics – name of player without photo; 
12 – dislay the Guest graphics – name of guest at game; 13 –  display the Timer graphics – time of 
current period; 14 – table with list of players of team 1; 15 – table with list of players of team 2; 16 – the 
Play check box – select all players (in each team) who participate game; 17 – Update data – update 
information in teams table (if changes in SLSpotrTimesEditor Database are made); 18 – preview 
window of graphics selected for streaming; 19 – area with graphics buttons with general information 
about game; 20 – display the DownScore graphics – score of game is at the bottom of screen; 21 – 
GeoTitle – graphics with name of championship, teams, cities and logotypes; 22 – Referees – graphics 
with referees of game (names, photos); 23 – RefereesNoPhoto – graphics with referees of game without 
photo; 24 – display the TotalScore graphics – total score of game.
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5.4. Commands of the Main Menu

Table.	 Main menu commands 

Menu command Action

1. File – commands used to create and save graphics display project file
New Create new project (the *.SLSportTitleCfg file).
Load Load earlier created project.
Save (Ctrl+S) Save current project to the same file.
Save as*** Save current project to new file.
Start Start graphics display.
Stop Stop graphics display.
Exit (Alt+F4) Finish work with program.

2. Options – commands used to confiure interface of graphics display 
Grid configurations Open the Grid configuration window – specify grid parameters 

to locate interface buttons:
Rows count – quantity of horizontal rows; 
Columns count – quantity of columns.

Configure tabs Open the Tab configurations window to create/delete tabs with 
a set of graphics buttons used for games streaming. 

Configure views Open the View plug-ins config window to configure tables with 
set of teams.

Configure buttons Open the Title plug-ins config window to configure set of graphics 
buttons on tab (Sostav, Coach, DressingRoom, TimeOut, UpScore, 
Bullits, Player, etc.)

Configure special buttons Open the Special buttons config window to configure hot keys 
and GPI events for commands of control output of prepared 
graphics buttons on air:
StopAll – stop display of all graphics; 
AbortAll – Escape – graphics fades out quickly (FadeOut) 
without animation; 
Take – F1 – output graphics on air.

Configure preview Open the Preview configuration window to configure size of 
graphics preview window.

Options Open the Options configuration window to configure colours of 
displayed graphics status and to select output device in the 
Board type list (select available FDExt board).

3. Group’s commands – commands used to display group of graphics 
Stop default group Stop display of current graphics in group of graphics by 

default.
Stop group 1 Stop display of current graphics from group 1.
Stop group 2 Stop display of current graphics from group 2.
Stop group 3 Stop display of current graphics from group 3.
Abort all Stop display of graphics without animation, via FadeOut.
Stop all Stop display of graphics.
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Menu command Action

Take Start output of graphics on air.
Use global short cuts Enables mode of synchronous operation of hot keys for all 

programs of system.

5.5. Configuration of Program Interface
1.	 Complete the File > Stop menu command to change interface 

of the SLSportTitler program. The system is provided with 
ready settings as a rule. 

1

2

4

2.	 The Configure grid command (2) activates the Grid configura-
tion window (3) to customize grid to locate graphics buttons 
there. Default size of grid is 20х6. Rows count is quantity 
of horizontal rows, Columns count is a quantity of vertical 
columns.

3

3.	 The Configure tabs button (4) activates the Tab configura-
tion window (5) to create/delete (Add (8) and Remove buttons 
(9)) tabs with a set of graphics buttons. Specify name of tab 
in the Title field (7). All tabs are displayed in the (6) list.
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5

6

7

8 9

4.	 The Options > Configure views menu command activates the 
View plug-ins config window (10) to configure interposition of 
elements of window interface by grid. The Show config button 
(11) activates the Player view config window (12) to customize 
configuration of tables with lists of teams (Name, Role, +)(13) 
and path to game database (14). 

10

11

12

13

14
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5.	 The Options > Configure button menu command activates the 
Title plug-ins config window (15) to configure graphics buttons: 
list of buttons (16), locaiton on program tab (17), graphics 
of Name button (18), number of Group number (19), Processors 
number (20) – quantity of processor cores used for generation 
of graphics, configuration of hot keys (21), configuration of 
GPI events (22), list of graphics types Title plug-in (23) – more 
often Static info title Plug-in displays state of data when button 
is released.

     

     

15

16 17

19

20

18

21

22

23
24

Click Show config (24). Different windows for configuration in 
the Title plug-in list (23) open depending on type of graphics. 
For example, Goal plug-in configuration (25).
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23

25

●● FIBA time title plug-in – display of dynamic information in 
basketball;

●● FIVB title plug-in – display of dynamic information in 
volleyball;

●● Goal title plug-in – display of dynamic information in 
hockey/handball;

●● PlayerShots title plug-in – display of field for shoots with 
FIBA design;

●● Shootouts title plug-in – display of shootouts in hockey;
●● Static info title plug-in – configuration of any parameters 
in static format (data is imported when the button is 
released and remains unchanged at its display).

6.	 The Options > Configure special buttons menu command 
activates the Special buttons config window (26) to configure 
hot keys for commands of the main menu (27): StopAll, Abor-
tAll, StopDefault, StopGroup1***3, Take and GPI Event (28). 
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26

27

28

7.	 The Options > Configure preview menu command activates the 
Preview configuration window (29) to configure aspect ratio of 
graphics preview window (30). Span is a quantity of rows/
columns assigned to one button. Row is a coordinate of the 
left upper corner of window above (number of the upper 
row), Row span is a height of window, Column is a coordinate 
of the left upper corner on the left (number of column on the 
left), Column span is width of window.

29

30
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8.	 The Options > Options main menu command activates the 
Options configuration window (28) to configure colours for 
different states of graphics buttons (29) and to select device 
for displaying Board config (30) – FDExt input-output board.

●● Red Running state color – graphics is generated to start 
displaying (is not ready to be displayed);

●● Green Stopping state color – graphics is finished to be 
generated (is ready for display) and it generates data 
for end of display;

●● Blue Run state color – dynamic graphics, it has passed 
the Running step but hasn’t start the Stopping step yet.

28

29

30

5.6. Control Over Titles Display 
1. At start of the SLSportTitler program earlier created 
*.SLSportTitlerCfg graphics project in the SLSportTeamsEditor 
and SLIceHockeyReferee programs is opened. Also user can 
work with the File > Load command of the main program menu 
to open necessary project there. 
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2.	 Execute the File > Start command (1) from the main program 
menu to start display of graphics. 

1
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3.	 Update lists of players who participate game in tables with 
teams. For this put/remove players check boxes (1) in Play 
column.

    

1

3 42

1

Use the following buttons to sort lists display:
●● № (2) – sorting list of players by numbers in ascending 
order;

●● Name (3) – sorting list of players by names in 
alphabetical order;

●● Role (4) – sorting list of players by role – goalkeepers 
(GOALTENDER), forwards (FORWARD), defenders 
(DEFENSEMEN).

Click Update data (5) to update data.
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4.	 Click corresponding graphics button (6) to output Sos-
tav graphics on air. Red colour denotes that graphics is 
prepared for broadcasting and is displayed in preview 
window (7) with specified animation.

6

7

The Sostav button becomes green (8) in preview window 
when animation is finished. It denotes that graphics is 
ready to be displayed. 

8 91011

Click the Take button (9) from the main button to output 
graphics on air.

5.	 User can stop display of graphics in several ways:
●● by clicking graphics button again;
●● by executing the Stop all command (10) of the main 
program menu – graphics disappears with final 
animation;
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●● by executing the Abort all command (11) of the main 
program menu – graphics fades out quickly (via the 
FadeOut without final animation).

6.	 Via some buttons user can output graphics on air without 
preview automatically. For example, display of upper score 
– the UpScore button (12) or Timer (13).

12

13
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Interface of Forward Sport Titles Software

Commnads of SLSportTeamsEditor Database Editor 

Configuration and control over completion of tables with 
database of game is executed via commands of the main 
program menu or buttons located on toolbar of each table editor. 

Table.	 Program commands

Menu command Button on toolbar/in 
window 

Action

1. File – commands used to create and save game database.
New Create new game.

Open Load information from database  
(*.TitleDB file).

Save (Ctrl+S) Save information to database.

Save as***   Save information to database in new 
file.
Monitor state of FIBA game.

Exit (Alt+F4) Finish work with program.
2. Edit – commands used to complete tables with information about game, teams, 
players. 

GAME table
Clear Clear information about game.

Import from CSV Import information about game from 
*.csv file.

Import information аbоut teams and 
players from FIBA log file.

Export to CSV Export information about game to 
*.csv file.
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Menu command Button on toolbar/in 
window 

Action

TRANSLATIONS table
Clear Clear information by default.

Import from CSV Import translations from*.csv file.

Export to CSV Export translations to *.csv file.

First team info table
Clear Clear information about the first 

team.

Import from CSV Import information about the first 
team from *.csv file.

Import from KHL database Import information about team and 
players from the first team from KHL 
database.

Export to CSV Export information about the first 
team to *.csv file.

Second team info table
Clear Clear information about the second 

team.

Import from CSV Import information about the second 
team from *.csv file.

Import from KHL database Import information about team and 
players from the second team from 
KHL database.

Export to CSV Export information about the second 
team to*.csv file.

First team players table
Clear Clear information about players from 

the first team.

Import from CSV Import information about players 
from the first team from *.csv file.

Export to CSV Export information about players 
from the first team to*.csv file.

Add new player to the first team. 

Delete selected player from the first 
team. 
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Menu command Button on toolbar/in 
window 

Action

Second team players table
Clear Clear information about players from 

the second team.

Import from CSV Import information about players 
from the second team from *.csv file.

Export to CSV Export information about players 
from the second team to*.csv file.

Add new player to the second team. 

Delete selected player from the second 
team. 

Settings Open the Settings window to provide 
access to statistics on KHL website 
(http://stat2tv.khl.ru).

3. Help – information about program.
About program*** Open window with a service data 

including information about version 
of Forward Sport Titles software 
version.
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